Intermittent 3DS issues

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 13:58 BST

Monitoring

A fix has been implemented and we are monitoring the results. We will provide a further update once we have confirmed full resolution on our end.
Posted Aug 18, 2026 - 13:44 BST

Update

We believe the issue is related to Lloyds Group and are continuing to investigate the issue.
Posted Aug 18, 2026 - 13:24 BST

Investigating

We are currently experiencing intermittent issues with our 3DS service. We are investigating the cause and will post timely updates as more information becomes available.
Posted Aug 18, 2026 - 13:16 BST
This incident affected: Card API.