Service degradation affecting the Hub

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 19:35 GMT

Investigating

We are currently experiencing a service degradation affecting the Hub. Some users may see reduced performance or intermittent issues. Our engineering team is investigating and working to restore normal service as quickly as possible. Further updates will follow.
Posted Feb 10, 2026 - 19:27 GMT
This incident affected: Hub.