Pay by Bank Unavailable via Hosted Checkout

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 12:42 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 10:26 BST

Identified

We are currently experiencing an issue with the Pay by Bank payments on our Hosted Checkout. Our team is investigating and working to resolve the issue as quickly as possible. Other payment methods remain unaffected. Direct API Pay by Bank integrations are not affected.
Posted Apr 25, 2025 - 09:08 BST
This incident affected: Pay by Bank.