Processing Issues: 3D Secure
Incident Report for Acquired.com
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 14:18 UTC
Monitoring
A fix has been implemented and we are monitoring the platform.
Posted Dec 18, 2023 - 11:14 UTC
Investigating
We are currently investigating this issue.
Posted Dec 18, 2023 - 11:04 UTC
This incident affected: 3-D Secure.