Processing Issues (MasterCard 3DS)
Incident Report for Acquired.com
Resolved
Services has been restored and Mastercard processing returned to normal.
Posted Jun 12, 2023 - 19:17 UTC
Update
The issue is still on-going and our teams are continuing to monitor traffic.

We will keep you update with any developments.
Posted Jun 12, 2023 - 14:52 UTC
Monitoring
Please be advised that customers may be experiencing intermittent 3DS transaction failures currently via MasterCard.

Visa and American Express authentication requests are unaffected.

Further information and updates will be provided in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@acquired.com or +44 203 982 6580.
Posted Jun 12, 2023 - 13:35 UTC
This incident affected: 3-D Secure.