Degraded Payment Processing & Hub Latency

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 19:56 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 17:38 BST

Update

We are continuing to investigate this issue.
Posted Jul 03, 2025 - 16:44 BST

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 16:34 BST
This incident affected: Card API, Hosted Payment Page, Hub, and REST API.