Third-party 3D Secure issue affecting some card payments

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Jun 07, 2026 - 14:24 BST

Monitoring

The issue appears to resolved and we are monitoring the results.
Posted Jun 07, 2026 - 14:23 BST

Investigating

We are investigating intermittent failures affecting 3D Secure (3DS) authentication on a small proportion of card transactions, caused by an issue with a third-party provider. Most payments are processing normally. Affected transactions may need to be retried. We are working with the provider to resolve this and will post an update shortly.
Posted Jun 07, 2026 - 13:40 BST
This incident affected: Product Pillars (Cards).