Issue processing 3D Secure enrolment

Incident Report for Acquired.com

Resolved

The issue has been resolved with processing returned to normal.
Posted Jul 17, 2026 - 07:28 BST

Monitoring

We have implemented a fix and are monitoring closely.
Posted Jul 17, 2026 - 07:15 BST

Update

We are continuing to investigate this issue.
Posted Jul 17, 2026 - 06:40 BST

Investigating

An issue has been identified in the 3D Secure processing that is causing transactions to be rejected. We're investigating the issue.
Posted Jul 17, 2026 - 06:30 BST
This incident affected: Product Pillars (Cards).