Hub Availability Issue

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted May 11, 2026 - 16:12 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 16:12 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 11, 2026 - 16:10 BST

Investigating

We are currently investigating an issue affecting the Acquired Hub. Payment processing is not impacted and continues to operate as normal. We will provide further updates as our investigation progresses.
Posted May 11, 2026 - 16:08 BST
This incident affected: Hub.