We are continuing to monitor for any further issues.
Posted Feb 27, 2026 - 11:51 GMT
Monitoring
The first phase of infrastructure capacity upgrades has now been successfully completed.
Transaction volumes remain elevated but processing performance has returned to expected levels, and we are no longer observing widespread latency.
We are continuing to deploy additional capacity enhancements as part of phase two and will closely monitor platform performance.
The incident status has now moved to Monitoring while we ensure stability is sustained.
We will provide a further update if there are any material changes.
Posted Feb 27, 2026 - 10:55 GMT
Update
We are continuing to investigate reports of delayed payment processing.
We are still experiencing significantly elevated transaction volumes, currently approximately 6–8× normal levels, which have contributed to increased processing latency.
We are rolling out two sets of infrastructure upgrades across the server estate to increase available capacity. The first set of changes, which is expected to have the highest performance impact, will complete within the next 15 minutes.
A second set of capacity enhancements is also being deployed in parallel and will continue to roll out in a controlled manner to allow traffic to drain and rebalance safely.
We are observing performance improvements and will provide a further update by 11:00 GMT.
Posted Feb 27, 2026 - 10:46 GMT
Update
We are continuing to investigate reports of delayed payment processing.
We are currently experiencing significantly elevated traffic levels, which are contributing to increased processing latency.
As an immediate mitigation, we are scaling additional infrastructure capacity, including CPU and memory resources, to stabilise performance while we continue root cause analysis.
No data integrity issues have been identified.
We will provide a further update by 10:45 GMT.
Posted Feb 27, 2026 - 10:17 GMT
Update
We are continuing to investigate this issue.
Posted Feb 27, 2026 - 09:56 GMT
Update
We are continuing to investigate this issue.
Posted Feb 27, 2026 - 09:38 GMT
Update
We are continuing to investigate this issue.
Posted Feb 27, 2026 - 09:18 GMT
Update
We are continuing to investigate this issue.
Posted Feb 27, 2026 - 08:41 GMT
Investigating
We are investigating reports of delayed payment processing. Our team is actively working to identify the cause and will share updates as soon as possible.
Posted Feb 27, 2026 - 08:14 GMT
This incident affected: Payments API, Hosted Payment Page and Integration Methods (Components, Hosted Checkout).