Trust Payments Settlement Delays

Incident Report for Acquired.com

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 13:17 GMT

Monitoring

We have been notified by our acquiring partner, Trust Payments, of a delay in their settlements today and they are working towards a solution.

For real-time updates, please refer to the Trust Payments status page:

https://status.trustpayments.com/

We will continue to monitor the situation and provide updates as we receive more information.

If you have any questions, please reach out to our support team.
Posted Jan 31, 2025 - 16:39 GMT
This incident affected: Card API, Hosted Payment Page, and REST API.