Service Disruption: Intermittent processing issues with Trust Payments
Incident Report for Acquired.com
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 11:43 UTC
Investigating
We are currently investigation this issue
Posted Feb 29, 2024 - 08:44 UTC
This incident affected: Card API, Hosted Payment Page, and REST API.